aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..3a4cdb1
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,27 @@
+[tool.poetry]
+name = "quarg"
+version = "0.1.0"
+description = "Search Quassel logs for matching messages and print them"
+authors = ["Wolfgang Müller <wolf@oriole.systems>"]
+license = "MIT"
+homepage = "https://oriole.systems/posts/quarg"
+repository = "https://git.oriole.systems/quarg"
+documentation = "https://git.oriole.systems/quarg/about"
+classifiers = [
+ "Operating System :: OS Independent"
+]
+
+[tool.poetry.dependencies]
+python = "^3.8"
+SQLAlchemy = "^1.4.0"
+python-dateutil = "^2.8.2"
+
+[tool.poetry.scripts]
+quarg = 'quarg.main:main'
+
+[tool.poetry.group.dev.dependencies]
+psycopg2-binary = "^2.9.5"
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"