aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/pyproject.toml
diff options
context:
space:
mode:
authorWolfgang Müller2023-03-30 20:54:27 +0200
committerWolfgang Müller2023-03-30 20:59:10 +0200
commit1c2e7e52e388bdb64bbb2190047e014ff33f973b (patch)
tree07b52a1d297750c70a10ebe0c1e2dc9d941f32af /pyproject.toml
parentf10377961aaf9294316569d3ec198a5a7ce093ab (diff)
downloadquarg-1c2e7e52e388bdb64bbb2190047e014ff33f973b.tar.gz
Migrate to poetry
We have used this in another project of ours and prefer its interface over pip's and its toml configuration over setup.py. There should be no functional change.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..3a4cdb1
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,27 @@
+[tool.poetry]
+name = "quarg"
+version = "0.1.0"
+description = "Search Quassel logs for matching messages and print them"
+authors = ["Wolfgang Müller <wolf@oriole.systems>"]
+license = "MIT"
+homepage = "https://oriole.systems/posts/quarg"
+repository = "https://git.oriole.systems/quarg"
+documentation = "https://git.oriole.systems/quarg/about"
+classifiers = [
+ "Operating System :: OS Independent"
+]
+
+[tool.poetry.dependencies]
+python = "^3.8"
+SQLAlchemy = "^1.4.0"
+python-dateutil = "^2.8.2"
+
+[tool.poetry.scripts]
+quarg = 'quarg.main:main'
+
+[tool.poetry.group.dev.dependencies]
+psycopg2-binary = "^2.9.5"
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"