aboutsummaryrefslogtreecommitdiffstats
path: root/app-backup/lifeboat/lifeboat-0.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/lifeboat/lifeboat-0.1.1.ebuild')
-rw-r--r--app-backup/lifeboat/lifeboat-0.1.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-backup/lifeboat/lifeboat-0.1.1.ebuild b/app-backup/lifeboat/lifeboat-0.1.1.ebuild
new file mode 100644
index 0000000..f36a8db
--- /dev/null
+++ b/app-backup/lifeboat/lifeboat-0.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3
+
+DESCRIPTION="Manage and automate local restic backups"
+HOMEPAGE="https://oriole.systems"
+EGIT_REPO_URI="https://git.oriole.systems/lifeboat.git"
+EGIT_COMMIT="${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-backup/restic"
+BDEPEND=""
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}