aboutsummaryrefslogtreecommitdiffstats
path: root/app-backup/lifeboat/lifeboat-0.1.1.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-01-13 15:59:49 +0100
committerWynn Wolf Arbor2020-01-13 15:59:49 +0100
commit90b60b5044587535e792ed5410acbf10a76963e7 (patch)
tree316d681581cb2b3a4218f31e72cab376e70b8252 /app-backup/lifeboat/lifeboat-0.1.1.ebuild
downloadpramantha-90b60b5044587535e792ed5410acbf10a76963e7.tar.gz
Initial import
Diffstat (limited to 'app-backup/lifeboat/lifeboat-0.1.1.ebuild')
-rw-r--r--app-backup/lifeboat/lifeboat-0.1.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-backup/lifeboat/lifeboat-0.1.1.ebuild b/app-backup/lifeboat/lifeboat-0.1.1.ebuild
new file mode 100644
index 0000000..f36a8db
--- /dev/null
+++ b/app-backup/lifeboat/lifeboat-0.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3
+
+DESCRIPTION="Manage and automate local restic backups"
+HOMEPAGE="https://oriole.systems"
+EGIT_REPO_URI="https://git.oriole.systems/lifeboat.git"
+EGIT_COMMIT="${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-backup/restic"
+BDEPEND=""
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}