aboutsummaryrefslogtreecommitdiffstats
path: root/www-apps/cgit/cgit-1.2.3-r1.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-05-24 19:55:41 +0200
committerWynn Wolf Arbor2020-05-24 19:55:41 +0200
commit00a8b2029c74ea7ecc1b4bd8c8f0de50127f1269 (patch)
treeff7b8a961d98145873ab582b7834c40e96183009 /www-apps/cgit/cgit-1.2.3-r1.ebuild
parentbe6ea31bad4c6a0f228750f58be1b0906e28aea0 (diff)
downloadpramantha-00a8b2029c74ea7ecc1b4bd8c8f0de50127f1269.tar.gz
www-apps/cgit: Bump to 1.2.3-r2
Fix build on musl-based systems by introducing NO_REGEX=NeedsStartEnd. Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to 'www-apps/cgit/cgit-1.2.3-r1.ebuild')
-rw-r--r--www-apps/cgit/cgit-1.2.3-r1.ebuild83
1 files changed, 0 insertions, 83 deletions
diff --git a/www-apps/cgit/cgit-1.2.3-r1.ebuild b/www-apps/cgit/cgit-1.2.3-r1.ebuild
deleted file mode 100644
index 10d8602..0000000
--- a/www-apps/cgit/cgit-1.2.3-r1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib toolchain-funcs
-
-GIT_V="2.25.1"
-
-DESCRIPTION="a fast web-interface for git repositories"
-HOMEPAGE="https://git.zx2c4.com/cgit/about"
-SRC_URI="https://www.kernel.org/pub/software/scm/git/git-${GIT_V}.tar.xz
- https://git.zx2c4.com/cgit/snapshot/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc highlight libressl lua luajit lzip markdown zip zstd"
-
-LUADEP="
- lua? (
- luajit? ( dev-lang/luajit )
- !luajit? ( dev-lang/lua:0 )
- )
-"
-
-BDEPEND="
- doc? ( app-text/docbook-xsl-stylesheets
- >=app-text/asciidoc-8.5.1 )
-"
-
-RDEPEND="${LUADEP}
- dev-vcs/git
- highlight? ( || ( dev-python/pygments app-text/highlight ) )
- lzip? ( app-arch/lzip )
- markdown? ( dev-python/markdown )
- zip? ( app-arch/zip )
- zstd? ( app-arch/zstd )
-"
-
-DEPEND="${LUADEP}
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- sys-libs/zlib
-"
-
-src_prepare() {
- default
-
- rmdir git || die
- mv "${WORKDIR}"/git-"${GIT_V}" git || die
-
- echo "prefix = ${EPREFIX}/usr" >> cgit.conf
- echo "libdir = ${EPREFIX}/usr/$(get_libdir)" >> cgit.conf
- echo "CACHE_ROOT = ${CGIT_CACHEDIR}" >> cgit.conf
- echo "DESTDIR = ${D}" >> cgit.conf
- if use lua; then
- if use luajit; then
- echo "LUA_PKGCONFIG = luajit" >> cgit.conf
- else
- echo "LUA_PKGCONFIG = lua" >> cgit.conf
- fi
- else
- echo "NO_LUA = 1" >> cgit.conf
- fi
-}
-
-src_compile() {
- emake V=1 AR="$(tc-getAR)" CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
- use doc && emake V=1 doc-man
-}
-
-src_install() {
- emake V=1 AR="$(tc-getAR)" CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" install
-
- dodoc README
- use doc && doman cgitrc.5
-}
-
-pkg_postinst() {
- ewarn "For caching support, /var/cache/cgit needs to exist and be owned"
- ewarn "by the user executing cgit."
-}