aboutsummaryrefslogtreecommitdiffstats
path: root/acct-user/caddy/caddy-1.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-05-25 14:29:59 +0200
committerWynn Wolf Arbor2020-05-25 14:29:59 +0200
commit2ea27a7de8ea0f09d55c2fb51a2485195b554542 (patch)
tree8e1b26601cdb09d8e55ce1d2e539f6a43dc3c73a /acct-user/caddy/caddy-1.ebuild
parentcfbf0ded2389798b1e7f3c64cdbd676b55fbf3e9 (diff)
downloadpramantha-2ea27a7de8ea0f09d55c2fb51a2485195b554542.tar.gz
acct-user/caddy: Bump to 1
Add ACCT_USER_HOME_OWNER and _PERMS instead of using diropts in the caddy ebuild itelf. Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to 'acct-user/caddy/caddy-1.ebuild')
-rw-r--r--acct-user/caddy/caddy-1.ebuild15
1 files changed, 15 insertions, 0 deletions
diff --git a/acct-user/caddy/caddy-1.ebuild b/acct-user/caddy/caddy-1.ebuild
new file mode 100644
index 0000000..33d74a0
--- /dev/null
+++ b/acct-user/caddy/caddy-1.ebuild
@@ -0,0 +1,15 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+ACCT_USER_ID=-1
+ACCT_USER_HOME=/var/lib/caddy
+ACCT_USER_HOME_OWNER=caddy:root
+ACCT_USER_HOME_PERMS=0700
+ACCT_USER_GROUPS=( http )
+ACCT_USER_SHELL=-1
+
+acct-user_add_deps