aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/meson.build
diff options
context:
space:
mode:
authorWolfgang Müller2021-07-15 15:51:32 +0200
committerWolfgang Müller2021-07-15 16:04:28 +0200
commitf9b97a698936a5c0d745f92a5b0e2bba1a1dbdbd (patch)
treea49662a1e741c945a64b15579bc393b4e31b0046 /meson.build
parentaf62385aa1206f03beb18fb4ef94c6ed44aa8e73 (diff)
downloadweltschmerz-f9b97a698936a5c0d745f92a5b0e2bba1a1dbdbd.tar.gz
Install translated manuals
With at least one manual now fully translated, we need to install it to the right place in both the Makefile and meson.build. For the former use a similar loop as is in use for the MO files. For the latter we sadly need to place the manual manually using install_data() because meson only supports localized manuals natively starting at 0.58.0, a version that is only about two months old.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 4bae2de..9284ba8 100644
--- a/meson.build
+++ b/meson.build
@@ -20,6 +20,11 @@ executable('weltschmerz', sources, dependencies: dependencies, install: true)
install_man('weltschmerz.1')
+# install_man supports locale only on meson >= 0.58.0, so let's wait a bit
+# until we rely on that
+install_data('weltschmerz.de.1',
+ install_dir: join_paths(get_option('mandir'), 'de', 'man1'), rename: 'weltschmerz.1')
+
i18n.merge_file(
input: 'weltschmerz.desktop.in',
output: 'weltschmerz.desktop',