aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/meson.build
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-03-28 15:10:55 +0100
committerWynn Wolf Arbor2020-04-13 15:45:26 +0200
commit30bbf529ad3073fd449c7f9331a889b114fad1e1 (patch)
treede43218ab0a4e4fc12816251144b55010e8c01a4 /meson.build
parentbed4cae59bfd5ac100caa3a4ac795f33598b6ab0 (diff)
downloadweltschmerz-30bbf529ad3073fd449c7f9331a889b114fad1e1.tar.gz
Add OSC 8 hyperlink support
This commit adds support for the OSC 8 hyperlink escape sequence [1]. As this is not a mature feature and there seem to be outstanding security concerns [2], the setting that controls whether or not OSC 8 is interpreted is disabled by default. Just like gnome-terminal, weltschmerz will display a tooltip with the canonicalized URI when hovering over a hyperlink. [1] https://gist.github.com/egmontkob/eb114294efbcd5adb1944c9f3cb5feda [2] https://gist.github.com/egmontkob/eb114294efbcd5adb1944c9f3cb5feda#security
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 485ce8e..dc83f80 100644
--- a/meson.build
+++ b/meson.build
@@ -11,7 +11,7 @@ dependencies = [
dependency('vte-2.91'),
]
-sources = files('weltschmerz.vala', 'terminal.vala', 'config.vala', 'configreader.vala')
+sources = files('weltschmerz.vala', 'terminal.vala', 'config.vala', 'configreader.vala', 'utils.vala')
sources += gnome.compile_resources('resources', 'resources.xml')
executable('weltschmerz', sources, dependencies: dependencies, install: true)