aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/meson.build
diff options
context:
space:
mode:
authorWynn Wolf Arbor2019-10-30 19:11:16 +0100
committerWynn Wolf Arbor2020-02-04 14:33:13 +0100
commit00702a3b764139a28b4de89f48ec1e38f1c58150 (patch)
tree8ab9563b3d462a60335ec489d2371df474201d0d /meson.build
parentf72f05cd8e157e5f433dca21de2a8d7fb2411436 (diff)
downloadweltschmerz-00702a3b764139a28b4de89f48ec1e38f1c58150.tar.gz
Improve configuration handling
This commit improves and simplifies weltschmerz's configuration handling. Obtaining and parsing the KeyFile is split out into ConfigReader, which is fully agnostic of the specific configuration values. Config now contains all configuration values in the form of primitive types or class instances, and no longer delegates access to the KeyFile structure directly. This means that the configuration file is read once, and then kept in the Config instance. Indirectly this commit also fixes a bug where weltschmerz would segfault if one of the palette entries contained an invalid value.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ea90630..485ce8e 100644
--- a/meson.build
+++ b/meson.build
@@ -11,7 +11,7 @@ dependencies = [
dependency('vte-2.91'),
]
-sources = files('weltschmerz.vala', 'terminal.vala', 'config.vala')
+sources = files('weltschmerz.vala', 'terminal.vala', 'config.vala', 'configreader.vala')
sources += gnome.compile_resources('resources', 'resources.xml')
executable('weltschmerz', sources, dependencies: dependencies, install: true)