aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..4788ac8
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,33 @@
+[tool.poetry]
+name = "quarg"
+version = "1.0.0"
+description = "Search Quassel logs for matching messages and print them"
+authors = ["Wolfgang Müller <wolf@oriole.systems>"]
+license = "MIT"
+homepage = "https://oriole.systems/posts/quarg"
+repository = "https://git.oriole.systems/quarg"
+documentation = "https://git.oriole.systems/quarg/about"
+classifiers = [
+ "Operating System :: OS Independent"
+]
+
+[tool.poetry.dependencies]
+python = "^3.8"
+SQLAlchemy = "^2.0.0"
+python-dateutil = "^2.8.2"
+
+[tool.poetry.scripts]
+quarg = 'quarg.main:main'
+
+[tool.poetry.group.dev.dependencies]
+ruff = "^0.3.1"
+psycopg-binary = "^3.1.8"
+psycopg = "^3.1.8"
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"
+
+[tool.ruff.lint]
+select = ["E", "F", "I", "W"]
+ignore = ["E501"]