aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/pyproject.toml
diff options
context:
space:
mode:
authorWolfgang Müller2023-03-30 21:26:07 +0200
committerWolfgang Müller2023-03-30 21:28:34 +0200
commit663167359693331941a0a510a17a88c70185a310 (patch)
tree77e5959468259fea197565a9dcb39142a89cee97 /pyproject.toml
parent73819ce2aad0b66b4858d207ab1f865ee8f22e5c (diff)
downloadquarg-663167359693331941a0a510a17a88c70185a310.tar.gz
Migrate to SQLAlchemy 2.0
This needs very few changes: - Use declarative_base from sqlalchemy.orm instead of ext [1] - Enable the future flag on both engine and session [1] https://docs.sqlalchemy.org/en/20/errors.html#error-b8d9
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 32d4a35..e2a8c0d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -13,7 +13,7 @@ classifiers = [
[tool.poetry.dependencies]
python = "^3.8"
-SQLAlchemy = "^1.4.0"
+SQLAlchemy = "^2.0.0"
python-dateutil = "^2.8.2"
[tool.poetry.scripts]