aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/pyproject.toml
diff options
context:
space:
mode:
authorWolfgang Müller2023-03-30 21:37:23 +0200
committerWolfgang Müller2023-03-30 21:37:23 +0200
commit056ff5108e14353b110290c32a697fdee4ea7b3e (patch)
tree589cdae612dfbaac2b7af5e9eed36e87a57dc70e /pyproject.toml
parente98b2c6b16b63752c0ccccc3ef9a2b4eafe5ad47 (diff)
downloadquarg-056ff5108e14353b110290c32a697fdee4ea7b3e.tar.gz
Migrate to psycopg3
SQLAlchemy 2.0 brings support for the latest version of the psycopg PostgreSQL database driver. With the migration to 2.0 done, we can switch to this now.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e2a8c0d..6cfc36c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -20,8 +20,9 @@ python-dateutil = "^2.8.2"
quarg = 'quarg.main:main'
[tool.poetry.group.dev.dependencies]
-psycopg2-binary = "^2.9.5"
ruff = "^0.0.260"
+psycopg-binary = "^3.1.8"
+psycopg = "^3.1.8"
[build-system]
requires = ["poetry-core"]