aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/cwm/cwm-6.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/cwm/cwm-6.6.ebuild')
-rw-r--r--x11-wm/cwm/cwm-6.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-wm/cwm/cwm-6.6.ebuild b/x11-wm/cwm/cwm-6.6.ebuild
new file mode 100644
index 0000000..7d75c9c
--- /dev/null
+++ b/x11-wm/cwm/cwm-6.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils toolchain-funcs
+
+DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
+ https://github.com/leahneukirchen/cwm"
+SRC_URI="http://leahneukirchen.org/releases/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+
+BDEPEND="
+ virtual/pkgconfig"
+DEPEND="x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -D_GNU_SOURCE" CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc README
+ make_session_desktop ${PN} ${PN}
+}