aboutsummaryrefslogtreecommitdiffstats
path: root/www-misc/slowcgi/slowcgi-6.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc/slowcgi/slowcgi-6.8.ebuild')
-rw-r--r--www-misc/slowcgi/slowcgi-6.8.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/www-misc/slowcgi/slowcgi-6.8.ebuild b/www-misc/slowcgi/slowcgi-6.8.ebuild
new file mode 100644
index 0000000..8ed5723
--- /dev/null
+++ b/www-misc/slowcgi/slowcgi-6.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="a FastCGI to CGI wrapper server"
+HOMEPAGE="https://git.oriole.systems/slowcgi"
+SRC_URI="https://git.oriole.systems/slowcgi/snapshot/${P}.tar.gz"
+
+RESTRICT="mirror"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ acct-user/slowcgi
+ acct-group/http"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-Add-flag-to-run-in-the-foreground.patch"
+)
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/slowcgi.initd slowcgi
+ newconfd "${FILESDIR}"/slowcgi.confd slowcgi
+}