aboutsummaryrefslogtreecommitdiffstats
path: root/www-misc/skein/skein-0.1.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc/skein/skein-0.1.3-r1.ebuild')
-rw-r--r--www-misc/skein/skein-0.1.3-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/www-misc/skein/skein-0.1.3-r1.ebuild b/www-misc/skein/skein-0.1.3-r1.ebuild
new file mode 100644
index 0000000..ae33b4d
--- /dev/null
+++ b/www-misc/skein/skein-0.1.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_METHOD="signify"
+inherit verify-sig
+
+DESCRIPTION="secure cgit hosting with slowcgi(8)"
+HOMEPAGE="https://git.oriole.systems/skein"
+SRC_URI="
+ https://git.oriole.systems/${PN}/snapshot/${P}.tar.gz
+ verify-sig? (
+ https://git.oriole.systems/${PN}/snapshot/${P}.tar.gz.asc
+ -> ${P}.sha.sig
+ )
+"
+
+RESTRICT="mirror"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="www-misc/slowcgi"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/signify-keys/oriole-systems-20240330.pub"
+
+src_unpack() {
+ if use verify-sig; then
+ cp "${DISTDIR}"/${P}.{sha.sig,tar.gz} "${WORKDIR}" || die
+ verify-sig_verify_signed_checksums \
+ ${P}.sha.sig sha256 ${P}.tar.gz
+ fi
+ default
+}
+
+src_compile() {
+ emake LDFLAGS="-static"
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/skein-infra.initd skein-infra
+}