aboutsummaryrefslogtreecommitdiffstats
path: root/sys-power/upp/upp-0.1.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/upp/upp-0.1.7.ebuild')
-rw-r--r--sys-power/upp/upp-0.1.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-power/upp/upp-0.1.7.ebuild b/sys-power/upp/upp-0.1.7.ebuild
new file mode 100644
index 0000000..f697ec6
--- /dev/null
+++ b/sys-power/upp/upp-0.1.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11,12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="A tool for parsing, dumping and modifying data in Radeon PowerPlay tables"
+HOMEPAGE="https://github.com/sibradzic/upp https://pypi.org/project/upp/"
+
+KEYWORDS="amd64 x86"
+
+RESTRICT="test"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/click[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"