aboutsummaryrefslogtreecommitdiffstats
path: root/sys-fs/zfs_autobackup/zfs_autobackup-3.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/zfs_autobackup/zfs_autobackup-3.1.2.ebuild')
-rw-r--r--sys-fs/zfs_autobackup/zfs_autobackup-3.1.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-fs/zfs_autobackup/zfs_autobackup-3.1.2.ebuild b/sys-fs/zfs_autobackup/zfs_autobackup-3.1.2.ebuild
new file mode 100644
index 0000000..4a895c4
--- /dev/null
+++ b/sys-fs/zfs_autobackup/zfs_autobackup-3.1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10} )
+inherit distutils-r1
+
+DESCRIPTION="Periodicly backup ZFS filesystems"
+HOMEPAGE="https://github.com/psy0rz/zfs_autobackup https://pypi.org/project/zfs-autobackup/"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="amd64 x86"
+
+RESTRICT="test"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/colorama[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"