aboutsummaryrefslogtreecommitdiffstats
path: root/sys-apps/rw/rw-1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/rw/rw-1.0.ebuild')
-rw-r--r--sys-apps/rw/rw-1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-apps/rw/rw-1.0.ebuild b/sys-apps/rw/rw-1.0.ebuild
new file mode 100644
index 0000000..f7fddc2
--- /dev/null
+++ b/sys-apps/rw/rw-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A dd replacement from the Sortix operating system"
+HOMEPAGE="https://sortix.org/rw/"
+SRC_URI="https://sortix.org/rw/release/${PN}-portable-${PV}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+RESTRICT="mirror"
+
+src_unpack() {
+ default
+ mv "${WORKDIR}/${PN}-portable-${PV}" "${S}"
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}