aboutsummaryrefslogtreecommitdiffstats
path: root/sys-apps/mandoc/mandoc-1.14.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/mandoc/mandoc-1.14.5.ebuild')
-rw-r--r--sys-apps/mandoc/mandoc-1.14.5.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/mandoc/mandoc-1.14.5.ebuild b/sys-apps/mandoc/mandoc-1.14.5.ebuild
new file mode 100644
index 0000000..f8d78a7
--- /dev/null
+++ b/sys-apps/mandoc/mandoc-1.14.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A suite of tools compiling mdoc from the OpenBSD project"
+HOMEPAGE="http://mdocml.bsd.lv/"
+SRC_URI="http://mdocml.bsd.lv/snapshots/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="mirror"
+
+IUSE="+cron static"
+
+RDEPEND="static? ( sys-libs/zlib[static-libs(+)] )
+ !sys-apps/man-db !sys-apps/man"
+
+DEPEND="static? ( sys-libs/zlib )"
+
+src_configure() {
+ cp "${FILESDIR}/configure.local" . || die
+
+ # Add Gentoo CFLAGS
+ echo 'CFLAGS="$CFLAGS' ${CFLAGS}\" >> configure.local
+
+ if use static; then
+ echo 'LDFLAGS="$LDFLAGS -static"' >> configure.local
+ fi
+
+ default
+}
+
+src_install() {
+ default
+
+ if use cron; then
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/mandoc.cron mandoc
+ fi
+}
+
+pkg_postinst() {
+ elog "In order to enable mandoc's apropos and man -k functionality,"
+ elog "the appropriate mandoc.db files need to be created. This can be"
+ elog "achieved by running makewhatis as root (sudo will not work)."
+ elog
+ elog "If the cron use-flag is enabled, a cron.daily entry that calls"
+ elog "makewhatis will be installed."
+}