aboutsummaryrefslogtreecommitdiffstats
path: root/net-misc/gandi-cli/gandi-cli-1.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/gandi-cli/gandi-cli-1.6.ebuild')
-rw-r--r--net-misc/gandi-cli/gandi-cli-1.6.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/net-misc/gandi-cli/gandi-cli-1.6.ebuild b/net-misc/gandi-cli/gandi-cli-1.6.ebuild
deleted file mode 100644
index e43dd8d..0000000
--- a/net-misc/gandi-cli/gandi-cli-1.6.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{10,11} pypy )
-
-inherit distutils-r1
-
-MY_PN="${PN//-/.}"
-DESCRIPTION="CLI to easily create and manage web resources for your Gandi account."
-HOMEPAGE="https://github.com/Gandi/gandi.cli"
-SRC_URI="https://github.com/Gandi/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
-"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=dev-python/click-7
- dev-python/requests
- dev-python/pyyaml
- dev-python/IPy
- dev-python/namespace-gandi
-"
-
-DEPEND="dev-python/namespace-gandi"
-
-RESTRICT="mirror"
-
-S=${WORKDIR}/${MY_PN}-${PV}
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}