aboutsummaryrefslogtreecommitdiffstats
path: root/net-misc/gandi-cli/gandi-cli-1.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/gandi-cli/gandi-cli-1.5-r1.ebuild')
-rw-r--r--net-misc/gandi-cli/gandi-cli-1.5-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/gandi-cli/gandi-cli-1.5-r1.ebuild b/net-misc/gandi-cli/gandi-cli-1.5-r1.ebuild
new file mode 100644
index 0000000..1d0ad0b
--- /dev/null
+++ b/net-misc/gandi-cli/gandi-cli-1.5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+DESCRIPTION="CLI to easily create and manage web resources for your Gandi account."
+HOMEPAGE="https://github.com/Gandi/gandi.cli"
+SRC_URI="https://github.com/Gandi/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/click-7
+ dev-python/requests
+ dev-python/pyyaml
+ dev-python/ipy
+ dev-python/namespace-gandi
+"
+
+DEPEND="dev-python/namespace-gandi"
+
+RESTRICT="mirror"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}