aboutsummaryrefslogtreecommitdiffstats
path: root/net-misc/gandi-cli/gandi-cli-1.5-r1.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-04-19 19:04:24 +0200
committerWynn Wolf Arbor2020-04-19 19:04:24 +0200
commitc027e808c3785b5490e259381f25cbd8b94794c9 (patch)
treebef414c9a938bd53056b13977b5d3e074a1947b2 /net-misc/gandi-cli/gandi-cli-1.5-r1.ebuild
parent212c276c7a1adc636349628164228240838b17b4 (diff)
downloadpramantha-c027e808c3785b5490e259381f25cbd8b94794c9.tar.gz
net-misc/gandi-cli: Bump to 1.5-r1
This updates the ebuild to EAPI 7 and drops support for older python versions. Package-Manager: Portage-2.3.89, Repoman-2.3.20
Diffstat (limited to 'net-misc/gandi-cli/gandi-cli-1.5-r1.ebuild')
-rw-r--r--net-misc/gandi-cli/gandi-cli-1.5-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/gandi-cli/gandi-cli-1.5-r1.ebuild b/net-misc/gandi-cli/gandi-cli-1.5-r1.ebuild
new file mode 100644
index 0000000..1d0ad0b
--- /dev/null
+++ b/net-misc/gandi-cli/gandi-cli-1.5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+DESCRIPTION="CLI to easily create and manage web resources for your Gandi account."
+HOMEPAGE="https://github.com/Gandi/gandi.cli"
+SRC_URI="https://github.com/Gandi/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/click-7
+ dev-python/requests
+ dev-python/pyyaml
+ dev-python/ipy
+ dev-python/namespace-gandi
+"
+
+DEPEND="dev-python/namespace-gandi"
+
+RESTRICT="mirror"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}