aboutsummaryrefslogtreecommitdiffstats
path: root/net-irc/quarg/quarg-1.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/quarg/quarg-1.0.0-r1.ebuild')
-rw-r--r--net-irc/quarg/quarg-1.0.0-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-irc/quarg/quarg-1.0.0-r1.ebuild b/net-irc/quarg/quarg-1.0.0-r1.ebuild
new file mode 100644
index 0000000..1bef5ee
--- /dev/null
+++ b/net-irc/quarg/quarg-1.0.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11,12} )
+DISTUTILS_USE_PEP517=poetry
+
+VERIFY_SIG_METHOD="signify"
+inherit distutils-r1 verify-sig
+
+DESCRIPTION="Search Quassel logs for matching messages and print them"
+HOMEPAGE="https://git.oriole.systems/quarg"
+SRC_URI="
+ https://git.oriole.systems/${PN}/snapshot/${P}.tar.gz
+ verify-sig? (
+ https://git.oriole.systems/${PN}/snapshot/${P}.tar.gz.asc
+ -> ${P}.sha.sig
+ )
+"
+KEYWORDS="amd64 x86"
+
+RESTRICT="mirror test"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="sqlite postgres"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )
+ >=dev-python/sqlalchemy-2.0[${PYTHON_USEDEP},sqlite?]
+"
+
+DEPEND="${RDEPEND}"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/signify-keys/oriole-systems-20240330.pub"
+
+src_unpack() {
+ if use verify-sig; then
+ cp "${DISTDIR}"/${P}.{sha.sig,tar.gz} "${WORKDIR}" || die
+ verify-sig_verify_signed_checksums \
+ ${P}.sha.sig sha256 ${P}.tar.gz
+ fi
+ default
+}
+
+python_install_all() {
+ default
+
+ doman quarg.1
+}