aboutsummaryrefslogtreecommitdiffstats
path: root/media-sound/mpdevil/mpdevil-1.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mpdevil/mpdevil-1.9.0.ebuild')
-rw-r--r--media-sound/mpdevil/mpdevil-1.9.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/mpdevil/mpdevil-1.9.0.ebuild b/media-sound/mpdevil/mpdevil-1.9.0.ebuild
new file mode 100644
index 0000000..dc0455d
--- /dev/null
+++ b/media-sound/mpdevil/mpdevil-1.9.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9,10} )
+inherit python-single-r1 gnome2-utils meson xdg
+
+DESCRIPTION="A simple music browser for MPD"
+HOMEPAGE="https://github.com/SoongNoonien/mpdevil"
+SRC_URI=""
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SoongNoonien/${PN}.git"
+else
+ SRC_URI="https://github.com/SoongNoonien/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/gobject-introspection:=
+ x11-libs/gtk+:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-mpd[${PYTHON_USEDEP}]
+ ')
+"
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}