aboutsummaryrefslogtreecommitdiffstats
path: root/media-sound/listenbrainz-mpd/listenbrainz-mpd-2.3.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/listenbrainz-mpd/listenbrainz-mpd-2.3.4.ebuild')
-rw-r--r--media-sound/listenbrainz-mpd/listenbrainz-mpd-2.3.4.ebuild221
1 files changed, 221 insertions, 0 deletions
diff --git a/media-sound/listenbrainz-mpd/listenbrainz-mpd-2.3.4.ebuild b/media-sound/listenbrainz-mpd/listenbrainz-mpd-2.3.4.ebuild
new file mode 100644
index 0000000..2c24ddf
--- /dev/null
+++ b/media-sound/listenbrainz-mpd/listenbrainz-mpd-2.3.4.ebuild
@@ -0,0 +1,221 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+ addr2line@0.21.0
+ adler@1.0.2
+ ahash@0.8.11
+ aho-corasick@1.1.3
+ allocator-api2@0.2.16
+ anstream@0.6.13
+ anstyle@1.0.6
+ anstyle-parse@0.2.3
+ anstyle-query@1.0.2
+ anstyle-wincon@3.0.2
+ anyhow@1.0.82
+ backtrace@0.3.71
+ base64@0.22.0
+ bitflags@1.3.2
+ bitflags@2.5.0
+ bumpalo@3.16.0
+ bytes@1.6.0
+ cc@1.0.92
+ cfg-if@1.0.0
+ clap@4.5.4
+ clap_builder@4.5.2
+ clap_complete@4.5.2
+ clap_derive@4.5.4
+ clap_lex@0.7.0
+ colorchoice@1.0.0
+ core-foundation@0.9.4
+ core-foundation-sys@0.8.6
+ dirs@5.0.1
+ dirs-sys@0.4.1
+ equivalent@1.0.1
+ errno@0.3.8
+ fallible-iterator@0.3.0
+ fallible-streaming-iterator@0.1.9
+ fastrand@2.0.2
+ fnv@1.0.7
+ foreign-types@0.3.2
+ foreign-types-shared@0.1.1
+ form_urlencoded@1.2.1
+ futures-channel@0.3.30
+ futures-core@0.3.30
+ futures-task@0.3.30
+ futures-util@0.3.30
+ getrandom@0.2.14
+ gimli@0.28.1
+ hashbrown@0.14.3
+ hashlink@0.9.0
+ heck@0.5.0
+ http@1.1.0
+ http-body@1.0.0
+ http-body-util@0.1.1
+ httparse@1.8.0
+ hyper@1.2.0
+ hyper-tls@0.6.0
+ hyper-util@0.1.3
+ idna@0.5.0
+ indexmap@2.2.6
+ ipnet@2.9.0
+ itoa@1.0.11
+ js-sys@0.3.69
+ lazy_static@1.4.0
+ libc@0.2.153
+ libredox@0.1.3
+ libsqlite3-sys@0.28.0
+ linux-raw-sys@0.4.13
+ log@0.4.21
+ matchers@0.1.0
+ memchr@2.7.2
+ mime@0.3.17
+ minimal-lexical@0.2.1
+ miniz_oxide@0.7.2
+ mio@0.8.11
+ mpd_client@1.4.1
+ mpd_protocol@1.0.3
+ native-tls@0.2.11
+ nom@7.1.3
+ nu-ansi-term@0.46.0
+ object@0.32.2
+ once_cell@1.19.0
+ openssl@0.10.64
+ openssl-macros@0.1.1
+ openssl-probe@0.1.5
+ openssl-sys@0.9.102
+ option-ext@0.2.0
+ overload@0.1.1
+ percent-encoding@2.3.1
+ pin-project@1.1.5
+ pin-project-internal@1.1.5
+ pin-project-lite@0.2.14
+ pin-utils@0.1.0
+ pkg-config@0.3.30
+ proc-macro2@1.0.79
+ quote@1.0.36
+ redox_users@0.4.5
+ regex@1.10.4
+ regex-automata@0.1.10
+ regex-automata@0.4.6
+ regex-syntax@0.6.29
+ regex-syntax@0.8.3
+ reqwest@0.12.3
+ rusqlite@0.31.0
+ rustc-demangle@0.1.23
+ rustix@0.38.32
+ rustls-pemfile@2.1.2
+ rustls-pki-types@1.4.1
+ ryu@1.0.17
+ schannel@0.1.23
+ sd-notify@0.4.1
+ security-framework@2.10.0
+ security-framework-sys@2.10.0
+ serde@1.0.197
+ serde_derive@1.0.197
+ serde_json@1.0.115
+ serde_spanned@0.6.5
+ serde_urlencoded@0.7.1
+ sharded-slab@0.1.7
+ signal-hook-registry@1.4.1
+ smallvec@1.13.2
+ socket2@0.5.6
+ strsim@0.11.1
+ syn@2.0.58
+ sync_wrapper@0.1.2
+ tempfile@3.10.1
+ thiserror@1.0.58
+ thiserror-impl@1.0.58
+ thread_local@1.1.8
+ tinyvec@1.6.0
+ tinyvec_macros@0.1.1
+ tokio@1.37.0
+ tokio-macros@2.2.0
+ tokio-native-tls@0.3.1
+ tokio-stream@0.1.15
+ toml@0.8.12
+ toml_datetime@0.6.5
+ toml_edit@0.22.9
+ tower@0.4.13
+ tower-layer@0.3.2
+ tower-service@0.3.2
+ tracing@0.1.40
+ tracing-attributes@0.1.27
+ tracing-core@0.1.32
+ tracing-log@0.2.0
+ tracing-subscriber@0.3.18
+ try-lock@0.2.5
+ unicode-bidi@0.3.15
+ unicode-ident@1.0.12
+ unicode-normalization@0.1.23
+ url@2.5.0
+ utf8parse@0.2.1
+ valuable@0.1.0
+ vcpkg@0.2.15
+ version_check@0.9.4
+ want@0.3.1
+ wasi@0.11.0+wasi-snapshot-preview1
+ wasm-bindgen@0.2.92
+ wasm-bindgen-backend@0.2.92
+ wasm-bindgen-futures@0.4.42
+ wasm-bindgen-macro@0.2.92
+ wasm-bindgen-macro-support@0.2.92
+ wasm-bindgen-shared@0.2.92
+ web-sys@0.3.69
+ winapi@0.3.9
+ winapi-i686-pc-windows-gnu@0.4.0
+ winapi-x86_64-pc-windows-gnu@0.4.0
+ windows-sys@0.48.0
+ windows-sys@0.52.0
+ windows-targets@0.48.5
+ windows-targets@0.52.4
+ windows_aarch64_gnullvm@0.48.5
+ windows_aarch64_gnullvm@0.52.4
+ windows_aarch64_msvc@0.48.5
+ windows_aarch64_msvc@0.52.4
+ windows_i686_gnu@0.48.5
+ windows_i686_gnu@0.52.4
+ windows_i686_msvc@0.48.5
+ windows_i686_msvc@0.52.4
+ windows_x86_64_gnu@0.48.5
+ windows_x86_64_gnu@0.52.4
+ windows_x86_64_gnullvm@0.48.5
+ windows_x86_64_gnullvm@0.52.4
+ windows_x86_64_msvc@0.48.5
+ windows_x86_64_msvc@0.52.4
+ winnow@0.6.6
+ winreg@0.52.0
+ zerocopy@0.7.32
+ zerocopy-derive@0.7.32
+"
+
+inherit cargo systemd
+
+DESCRIPTION="ListenBrainz submission client for MPD"
+HOMEPAGE="https://codeberg.org/elomatreb/listenbrainz-mpd"
+SRC_URI="https://codeberg.org/elomatreb/listenbrainz-mpd/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${CARGO_CRATE_URIS}"
+
+LICENSE="AGPL-3 Apache-2.0 BSD MIT unicode"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="systemd"
+
+S="${WORKDIR}/${PN}"
+
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+
+src_configure() {
+ local myfeatures=($(usev systemd))
+ cargo_src_configure
+}
+
+src_install() {
+ cargo_src_install
+
+ systemd_dounit listenbrainz-mpd.service
+ systemd_douserunit listenbrainz-mpd.service
+}