aboutsummaryrefslogtreecommitdiffstats
path: root/media-sound/listenbrainz-mpd/listenbrainz-mpd-2.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/listenbrainz-mpd/listenbrainz-mpd-2.3.2.ebuild')
-rw-r--r--media-sound/listenbrainz-mpd/listenbrainz-mpd-2.3.2.ebuild223
1 files changed, 223 insertions, 0 deletions
diff --git a/media-sound/listenbrainz-mpd/listenbrainz-mpd-2.3.2.ebuild b/media-sound/listenbrainz-mpd/listenbrainz-mpd-2.3.2.ebuild
new file mode 100644
index 0000000..bb9414d
--- /dev/null
+++ b/media-sound/listenbrainz-mpd/listenbrainz-mpd-2.3.2.ebuild
@@ -0,0 +1,223 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+ addr2line@0.21.0
+ adler@1.0.2
+ ahash@0.8.6
+ aho-corasick@1.1.2
+ allocator-api2@0.2.16
+ anstream@0.6.5
+ anstyle@1.0.4
+ anstyle-parse@0.2.3
+ anstyle-query@1.0.2
+ anstyle-wincon@3.0.2
+ anyhow@1.0.75
+ autocfg@1.1.0
+ backtrace@0.3.69
+ base64@0.21.5
+ bitflags@1.3.2
+ bitflags@2.4.1
+ bumpalo@3.14.0
+ bytes@1.5.0
+ cc@1.0.83
+ cfg-if@1.0.0
+ clap@4.4.11
+ clap_builder@4.4.11
+ clap_complete@4.4.4
+ clap_derive@4.4.7
+ clap_lex@0.6.0
+ colorchoice@1.0.0
+ core-foundation@0.9.4
+ core-foundation-sys@0.8.6
+ dirs@5.0.1
+ dirs-sys@0.4.1
+ encoding_rs@0.8.33
+ equivalent@1.0.1
+ errno@0.3.8
+ fallible-iterator@0.3.0
+ fallible-streaming-iterator@0.1.9
+ fastrand@2.0.1
+ fnv@1.0.7
+ foreign-types@0.3.2
+ foreign-types-shared@0.1.1
+ form_urlencoded@1.2.1
+ futures-channel@0.3.29
+ futures-core@0.3.29
+ futures-sink@0.3.29
+ futures-task@0.3.29
+ futures-util@0.3.29
+ getrandom@0.2.11
+ gimli@0.28.1
+ h2@0.3.22
+ hashbrown@0.14.3
+ hashlink@0.8.4
+ heck@0.4.1
+ http@0.2.11
+ http-body@0.4.6
+ httparse@1.8.0
+ httpdate@1.0.3
+ hyper@0.14.27
+ hyper-tls@0.5.0
+ idna@0.5.0
+ indexmap@2.1.0
+ ipnet@2.9.0
+ itoa@1.0.10
+ js-sys@0.3.66
+ lazy_static@1.4.0
+ libc@0.2.151
+ libredox@0.0.1
+ libsqlite3-sys@0.27.0
+ linux-raw-sys@0.4.12
+ log@0.4.20
+ matchers@0.1.0
+ memchr@2.6.4
+ mime@0.3.17
+ minimal-lexical@0.2.1
+ miniz_oxide@0.7.1
+ mio@0.8.10
+ mpd_client@1.3.0
+ mpd_protocol@1.0.2
+ native-tls@0.2.11
+ nom@7.1.3
+ nu-ansi-term@0.46.0
+ object@0.32.1
+ once_cell@1.19.0
+ openssl@0.10.61
+ openssl-macros@0.1.1
+ openssl-probe@0.1.5
+ openssl-sys@0.9.97
+ option-ext@0.2.0
+ overload@0.1.1
+ percent-encoding@2.3.1
+ pin-project-lite@0.2.13
+ pin-utils@0.1.0
+ pkg-config@0.3.27
+ proc-macro2@1.0.70
+ quote@1.0.33
+ redox_syscall@0.4.1
+ redox_users@0.4.4
+ regex@1.10.2
+ regex-automata@0.1.10
+ regex-automata@0.4.3
+ regex-syntax@0.6.29
+ regex-syntax@0.8.2
+ reqwest@0.11.22
+ rusqlite@0.30.0
+ rustc-demangle@0.1.23
+ rustix@0.38.28
+ ryu@1.0.16
+ schannel@0.1.22
+ sd-notify@0.4.1
+ security-framework@2.9.2
+ security-framework-sys@2.9.1
+ serde@1.0.193
+ serde_derive@1.0.193
+ serde_json@1.0.108
+ serde_spanned@0.6.4
+ serde_urlencoded@0.7.1
+ sharded-slab@0.1.7
+ signal-hook-registry@1.4.1
+ slab@0.4.9
+ smallvec@1.11.2
+ socket2@0.4.10
+ socket2@0.5.5
+ strsim@0.10.0
+ syn@2.0.41
+ system-configuration@0.5.1
+ system-configuration-sys@0.5.0
+ tempfile@3.8.1
+ thiserror@1.0.51
+ thiserror-impl@1.0.51
+ thread_local@1.1.7
+ tinyvec@1.6.0
+ tinyvec_macros@0.1.1
+ tokio@1.35.0
+ tokio-macros@2.2.0
+ tokio-native-tls@0.3.1
+ tokio-stream@0.1.14
+ tokio-util@0.7.10
+ toml@0.8.8
+ toml_datetime@0.6.5
+ toml_edit@0.21.0
+ tower-service@0.3.2
+ tracing@0.1.40
+ tracing-attributes@0.1.27
+ tracing-core@0.1.32
+ tracing-log@0.2.0
+ tracing-subscriber@0.3.18
+ try-lock@0.2.5
+ unicode-bidi@0.3.14
+ unicode-ident@1.0.12
+ unicode-normalization@0.1.22
+ url@2.5.0
+ utf8parse@0.2.1
+ valuable@0.1.0
+ vcpkg@0.2.15
+ version_check@0.9.4
+ want@0.3.1
+ wasi@0.11.0+wasi-snapshot-preview1
+ wasm-bindgen@0.2.89
+ wasm-bindgen-backend@0.2.89
+ wasm-bindgen-futures@0.4.39
+ wasm-bindgen-macro@0.2.89
+ wasm-bindgen-macro-support@0.2.89
+ wasm-bindgen-shared@0.2.89
+ web-sys@0.3.66
+ winapi@0.3.9
+ winapi-i686-pc-windows-gnu@0.4.0
+ winapi-x86_64-pc-windows-gnu@0.4.0
+ windows-sys@0.48.0
+ windows-sys@0.52.0
+ windows-targets@0.48.5
+ windows-targets@0.52.0
+ windows_aarch64_gnullvm@0.48.5
+ windows_aarch64_gnullvm@0.52.0
+ windows_aarch64_msvc@0.48.5
+ windows_aarch64_msvc@0.52.0
+ windows_i686_gnu@0.48.5
+ windows_i686_gnu@0.52.0
+ windows_i686_msvc@0.48.5
+ windows_i686_msvc@0.52.0
+ windows_x86_64_gnu@0.48.5
+ windows_x86_64_gnu@0.52.0
+ windows_x86_64_gnullvm@0.48.5
+ windows_x86_64_gnullvm@0.52.0
+ windows_x86_64_msvc@0.48.5
+ windows_x86_64_msvc@0.52.0
+ winnow@0.5.28
+ winreg@0.50.0
+ zerocopy@0.7.31
+ zerocopy-derive@0.7.31
+"
+
+inherit cargo systemd
+
+DESCRIPTION="ListenBrainz submission client for MPD"
+HOMEPAGE="https://codeberg.org/elomatreb/listenbrainz-mpd"
+SRC_URI="https://codeberg.org/elomatreb/listenbrainz-mpd/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${CARGO_CRATE_URIS}"
+
+LICENSE="AGPL-3 Apache-2.0 BSD MIT unicode"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="systemd"
+
+S="${WORKDIR}/${PN}"
+
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+
+src_configure() {
+ local myfeatures=($(usev systemd))
+ cargo_src_configure
+}
+
+src_install() {
+ cargo_src_install
+
+ systemd_dounit listenbrainz-mpd.service
+ systemd_douserunit listenbrainz-mpd.service
+}