aboutsummaryrefslogtreecommitdiffstats
path: root/media-sound/listenbrainz-mpd/listenbrainz-mpd-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/listenbrainz-mpd/listenbrainz-mpd-2.1.0.ebuild')
-rw-r--r--media-sound/listenbrainz-mpd/listenbrainz-mpd-2.1.0.ebuild190
1 files changed, 190 insertions, 0 deletions
diff --git a/media-sound/listenbrainz-mpd/listenbrainz-mpd-2.1.0.ebuild b/media-sound/listenbrainz-mpd/listenbrainz-mpd-2.1.0.ebuild
new file mode 100644
index 0000000..df0e01a
--- /dev/null
+++ b/media-sound/listenbrainz-mpd/listenbrainz-mpd-2.1.0.ebuild
@@ -0,0 +1,190 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+ ahash-0.7.6
+ anyhow-1.0.69
+ autocfg-1.1.0
+ base64-0.21.0
+ bitflags-1.3.2
+ bumpalo-3.12.0
+ bytes-1.4.0
+ cc-1.0.79
+ cfg-if-1.0.0
+ clap-4.1.8
+ clap_derive-4.1.8
+ clap_lex-0.3.2
+ core-foundation-0.9.3
+ core-foundation-sys-0.8.3
+ dirs-4.0.0
+ dirs-sys-0.3.7
+ encoding_rs-0.8.32
+ errno-0.2.8
+ errno-dragonfly-0.1.2
+ fallible-iterator-0.2.0
+ fallible-streaming-iterator-0.1.9
+ fastrand-1.9.0
+ fnv-1.0.7
+ foreign-types-0.3.2
+ foreign-types-shared-0.1.1
+ form_urlencoded-1.1.0
+ futures-channel-0.3.27
+ futures-core-0.3.27
+ futures-sink-0.3.27
+ futures-task-0.3.27
+ futures-util-0.3.27
+ getrandom-0.2.8
+ h2-0.3.16
+ hashbrown-0.12.3
+ hashlink-0.8.1
+ heck-0.4.1
+ hermit-abi-0.3.1
+ http-0.2.9
+ http-body-0.4.5
+ httparse-1.8.0
+ httpdate-1.0.2
+ hyper-0.14.25
+ hyper-tls-0.5.0
+ idna-0.3.0
+ indexmap-1.9.2
+ instant-0.1.12
+ io-lifetimes-1.0.6
+ ipnet-2.7.1
+ is-terminal-0.4.4
+ itoa-1.0.6
+ js-sys-0.3.61
+ lazy_static-1.4.0
+ libc-0.2.140
+ libsqlite3-sys-0.25.2
+ linux-raw-sys-0.1.4
+ log-0.4.17
+ matchers-0.1.0
+ memchr-2.5.0
+ mime-0.3.16
+ minimal-lexical-0.2.1
+ mio-0.8.6
+ mpd_client-1.0.0
+ mpd_protocol-1.0.0
+ native-tls-0.2.11
+ nom-7.1.3
+ nu-ansi-term-0.46.0
+ once_cell-1.17.1
+ openssl-0.10.45
+ openssl-macros-0.1.0
+ openssl-probe-0.1.5
+ openssl-sys-0.9.80
+ os_str_bytes-6.4.1
+ overload-0.1.1
+ percent-encoding-2.2.0
+ pin-project-lite-0.2.9
+ pin-utils-0.1.0
+ pkg-config-0.3.26
+ proc-macro-error-1.0.4
+ proc-macro-error-attr-1.0.4
+ proc-macro2-1.0.51
+ quote-1.0.23
+ redox_syscall-0.2.16
+ redox_users-0.4.3
+ regex-1.7.1
+ regex-automata-0.1.10
+ regex-syntax-0.6.28
+ reqwest-0.11.14
+ rusqlite-0.28.0
+ rustix-0.36.9
+ ryu-1.0.13
+ schannel-0.1.21
+ security-framework-2.8.2
+ security-framework-sys-2.8.0
+ serde-1.0.154
+ serde_derive-1.0.154
+ serde_json-1.0.94
+ serde_spanned-0.6.1
+ serde_urlencoded-0.7.1
+ sharded-slab-0.1.4
+ slab-0.4.8
+ smallvec-1.10.0
+ socket2-0.4.9
+ strsim-0.10.0
+ syn-1.0.109
+ tempfile-3.4.0
+ termcolor-1.2.0
+ thiserror-1.0.39
+ thiserror-impl-1.0.39
+ thread_local-1.1.7
+ tinyvec-1.6.0
+ tinyvec_macros-0.1.1
+ tokio-1.26.0
+ tokio-macros-1.8.2
+ tokio-native-tls-0.3.1
+ tokio-stream-0.1.12
+ tokio-util-0.7.7
+ toml-0.7.2
+ toml_datetime-0.6.1
+ toml_edit-0.19.5
+ tower-service-0.3.2
+ tracing-0.1.37
+ tracing-attributes-0.1.23
+ tracing-core-0.1.30
+ tracing-log-0.1.3
+ tracing-subscriber-0.3.16
+ try-lock-0.2.4
+ unicode-bidi-0.3.11
+ unicode-ident-1.0.8
+ unicode-normalization-0.1.22
+ url-2.3.1
+ valuable-0.1.0
+ vcpkg-0.2.15
+ version_check-0.9.4
+ want-0.3.0
+ wasi-0.11.0+wasi-snapshot-preview1
+ wasm-bindgen-0.2.84
+ wasm-bindgen-backend-0.2.84
+ wasm-bindgen-futures-0.4.34
+ wasm-bindgen-macro-0.2.84
+ wasm-bindgen-macro-support-0.2.84
+ wasm-bindgen-shared-0.2.84
+ web-sys-0.3.61
+ winapi-0.3.9
+ winapi-i686-pc-windows-gnu-0.4.0
+ winapi-util-0.1.5
+ winapi-x86_64-pc-windows-gnu-0.4.0
+ windows-sys-0.42.0
+ windows-sys-0.45.0
+ windows-targets-0.42.1
+ windows_aarch64_gnullvm-0.42.1
+ windows_aarch64_msvc-0.42.1
+ windows_i686_gnu-0.42.1
+ windows_i686_msvc-0.42.1
+ windows_x86_64_gnu-0.42.1
+ windows_x86_64_gnullvm-0.42.1
+ windows_x86_64_msvc-0.42.1
+ winnow-0.3.5
+ winreg-0.10.1
+"
+
+inherit cargo systemd
+
+DESCRIPTION="ListenBrainz submission client for MPD"
+HOMEPAGE="https://codeberg.org/elomatreb/listenbrainz-mpd"
+SRC_URI="https://codeberg.org/elomatreb/listenbrainz-mpd/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ $(cargo_crate_uris)"
+
+LICENSE="AGPL-3 Apache-2.0 BSD MIT unicode"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+
+src_install() {
+ cargo_src_install
+
+ systemd_dounit listenbrainz-mpd.service
+}