aboutsummaryrefslogtreecommitdiffstats
path: root/media-fonts/iosevka/iosevka-3.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-fonts/iosevka/iosevka-3.1.1.ebuild')
-rw-r--r--media-fonts/iosevka/iosevka-3.1.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-fonts/iosevka/iosevka-3.1.1.ebuild b/media-fonts/iosevka/iosevka-3.1.1.ebuild
new file mode 100644
index 0000000..45168f3
--- /dev/null
+++ b/media-fonts/iosevka/iosevka-3.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit font
+
+DESCRIPTION="Slender typeface for code, from code"
+HOMEPAGE="https://typeof.net/Iosevka/"
+SRC_URI="https://github.com/be5invis/${PN}/releases/download/v${PV}/pkg-iosevka-${PV}.zip
+curly? ( https://github.com/be5invis/${PN}/releases/download/v${PV}/pkg-iosevka-curly-${PV}.zip )
+curly-slab? ( https://github.com/be5invis/${PN}/releases/download/v${PV}/pkg-iosevka-curly-slab-${PV}.zip )
+aile? ( https://github.com/be5invis/${PN}/releases/download/v${PV}/pkg-iosevka-aile-${PV}.zip )
+etoile? ( https://github.com/be5invis/${PN}/releases/download/v${PV}/pkg-iosevka-etoile-${PV}.zip )
+sparkle? ( https://github.com/be5invis/${PN}/releases/download/v${PV}/pkg-iosevka-sparkle-${PV}.zip )"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="+curly curly-slab +aile etoile sparkle"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+FONT_S="${S}/ttc"
+FONT_SUFFIX="ttc"