aboutsummaryrefslogtreecommitdiffstats
path: root/dev-python/namespace-gandi/namespace-gandi-1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/namespace-gandi/namespace-gandi-1-r2.ebuild')
-rw-r--r--dev-python/namespace-gandi/namespace-gandi-1-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/namespace-gandi/namespace-gandi-1-r2.ebuild b/dev-python/namespace-gandi/namespace-gandi-1-r2.ebuild
new file mode 100644
index 0000000..3e4d303
--- /dev/null
+++ b/dev-python/namespace-gandi/namespace-gandi-1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} pypy )
+inherit python-r1
+
+DESCRIPTION="Namespace package declaration for gandi"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages"
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND="${PYTHON_DEPS}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_unpack() {
+ mkdir -p "${S}"/gandi || die
+ cat > "${S}"/gandi/__init__.py <<-EOF || die
+ __import__('pkg_resources').declare_namespace(__name__)
+ EOF
+}
+
+src_install() {
+ python_foreach_impl python_domodule gandi
+}