aboutsummaryrefslogtreecommitdiffstats
path: root/dev-python/markdown2/markdown2-2.3.8-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/markdown2/markdown2-2.3.8-r1.ebuild')
-rw-r--r--dev-python/markdown2/markdown2-2.3.8-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/markdown2/markdown2-2.3.8-r1.ebuild b/dev-python/markdown2/markdown2-2.3.8-r1.ebuild
new file mode 100644
index 0000000..83882a9
--- /dev/null
+++ b/dev-python/markdown2/markdown2-2.3.8-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Markdown language reimplementation"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://github.com/trentm/python-markdown2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/pygments[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PV}/0001-Fixed-code-highlighting-unit-tests.patch" )
+
+python_prepare_all() {
+ # [issue52, knownfailure]
+ rm -f test/tm-cases/issue52* || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd test || die
+ "${PYTHON}" test.py || die "Tests fail with ${EPYTHON}"
+}