aboutsummaryrefslogtreecommitdiffstats
path: root/app-portage/bosun/bosun-1.4.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/bosun/bosun-1.4.0-r1.ebuild')
-rw-r--r--app-portage/bosun/bosun-1.4.0-r1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/app-portage/bosun/bosun-1.4.0-r1.ebuild b/app-portage/bosun/bosun-1.4.0-r1.ebuild
deleted file mode 100644
index 0d8b279..0000000
--- a/app-portage/bosun/bosun-1.4.0-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-VERIFY_SIG_METHOD="signify"
-inherit verify-sig
-
-DESCRIPTION="Manage portage roles with stow(8)"
-HOMEPAGE="https://git.oriole.systems/bosun"
-SRC_URI="
- https://git.oriole.systems/${PN}/snapshot/${P}.tar.gz
- verify-sig? (
- https://git.oriole.systems/${PN}/snapshot/${P}.tar.gz.asc
- -> ${P}.sha.sig
- )
-"
-
-RESTRICT="mirror"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-DEPEND="app-admin/stow"
-RDEPEND="${DEPEND}"
-
-VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/signify-keys/oriole-systems-20240330.pub"
-
-src_unpack() {
- if use verify-sig; then
- cp "${DISTDIR}"/${P}.{sha.sig,tar.gz} "${WORKDIR}" || die
- verify-sig_verify_signed_checksums \
- ${P}.sha.sig sha256 ${P}.tar.gz
- fi
- default
-}
-
-src_compile() { :; }
-
-src_install() {
- emake PREFIX=/usr DESTDIR="${D}" install
-
- insinto /usr/share/fish/vendor_completions.d
- doins contrib/completion/bosun.fish
-}