aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava-plugins/fava-plugins-1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/fava-plugins/fava-plugins-1.0.ebuild')
-rw-r--r--app-office/fava-plugins/fava-plugins-1.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-office/fava-plugins/fava-plugins-1.0.ebuild b/app-office/fava-plugins/fava-plugins-1.0.ebuild
index 3683aea..e8f9377 100644
--- a/app-office/fava-plugins/fava-plugins-1.0.ebuild
+++ b/app-office/fava-plugins/fava-plugins-1.0.ebuild
@@ -3,6 +3,8 @@
EAPI=7
PYTHON_COMPAT=( python3_{9,10} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1
@@ -12,7 +14,6 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
-RDEPEND=">=app-office/beancount-2.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=app-office/beancount-2.0[${PYTHON_SINGLE_USEDEP}]"