aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/beancount/beancount-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/beancount/beancount-9999.ebuild')
-rw-r--r--app-office/beancount/beancount-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-office/beancount/beancount-9999.ebuild b/app-office/beancount/beancount-9999.ebuild
index 2f40006..723feae 100644
--- a/app-office/beancount/beancount-9999.ebuild
+++ b/app-office/beancount/beancount-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_9 )
DISTUTILS_USE_SETUPTOOLS="rdepend"
inherit distutils-r1 elisp-common
@@ -29,6 +29,7 @@ SITEFILE="50{PN}-mode-gentoo.el"
RDEPEND="
$(python_gen_cond_dep '
dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
>=dev-python/bottle-0.12[${PYTHON_USEDEP}]
>=dev-python/google-api-python-client-1.8.2[${PYTHON_USEDEP}]
>=dev-python/httplib2-0.10[${PYTHON_USEDEP}]
@@ -47,7 +48,7 @@ python_compile_all() {
}
python_install_all() {
- rm -rf "${ED}/usr/elisp" || die "removing erroneous elisp files failed"
+ rm -rf "${ED}/usr/elisp" || die "removing elisp files failed"
distutils-r1_python_install_all