aboutsummaryrefslogtreecommitdiffstats
path: root/app-editors/kakoune/kakoune-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/kakoune/kakoune-9999.ebuild')
-rw-r--r--app-editors/kakoune/kakoune-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-editors/kakoune/kakoune-9999.ebuild b/app-editors/kakoune/kakoune-9999.ebuild
new file mode 100644
index 0000000..d93cdb9
--- /dev/null
+++ b/app-editors/kakoune/kakoune-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mawww/kakoune.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/mawww/kakoune/releases/download/v${PV}/kakoune-${PV}.tar.bz2"
+ KEYWORDS="amd64"
+ RESTRICT="mirror"
+fi
+
+DESCRIPTION="Selection-oriented code editor inspired by vim"
+HOMEPAGE="https://kakoune.org"
+
+LICENSE="Unlicense"
+SLOT="0"
+IUSE="debug static"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="sys-libs/ncurses:0=[unicode]"
+DEPEND="${RDEPEND} virtual/pkgconfig"
+
+src_configure() {
+ tc-export CXX
+ export debug=$(usex debug)
+ export static=$(usex static)
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" PREFIX="${EPREFIX}/usr" docdir="${ED%/}/usr/share/doc/${PF}" install
+}