aboutsummaryrefslogtreecommitdiffstats
path: root/app-backup/lifeboat/lifeboat-0.4.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/lifeboat/lifeboat-0.4.2-r1.ebuild')
-rw-r--r--app-backup/lifeboat/lifeboat-0.4.2-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-backup/lifeboat/lifeboat-0.4.2-r1.ebuild b/app-backup/lifeboat/lifeboat-0.4.2-r1.ebuild
new file mode 100644
index 0000000..6493a66
--- /dev/null
+++ b/app-backup/lifeboat/lifeboat-0.4.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_METHOD="signify"
+inherit systemd verify-sig
+
+DESCRIPTION="Manage and automate local restic(1) backups"
+HOMEPAGE="https://git.oriole.systems/lifeboat"
+SRC_URI="
+ https://git.oriole.systems/${PN}/snapshot/${P}.tar.gz
+ verify-sig? (
+ https://git.oriole.systems/${PN}/snapshot/${P}.tar.gz.asc
+ -> ${P}.sha.sig
+ )
+"
+
+RESTRICT="mirror"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ acct-group/lifeboat
+ acct-user/lifeboat"
+
+RDEPEND="${DEPEND}
+ app-backup/restic
+ net-misc/rclone"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/signify-keys/oriole-systems-20240330.pub"
+
+src_unpack() {
+ if use verify-sig; then
+ cp "${DISTDIR}"/${P}.{sha.sig,tar.gz} "${WORKDIR}" || die
+ verify-sig_verify_signed_checksums \
+ ${P}.sha.sig sha256 ${P}.tar.gz
+ fi
+ default
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ systemd_dounit etc/systemd/${PN}@.{service,timer}
+}