aboutsummaryrefslogtreecommitdiffstats
path: root/app-backup/lifeboat/lifeboat-0.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/lifeboat/lifeboat-0.2.1.ebuild')
-rw-r--r--app-backup/lifeboat/lifeboat-0.2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-backup/lifeboat/lifeboat-0.2.1.ebuild b/app-backup/lifeboat/lifeboat-0.2.1.ebuild
new file mode 100644
index 0000000..411c1b5
--- /dev/null
+++ b/app-backup/lifeboat/lifeboat-0.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Manage and automate local restic(1) backups"
+HOMEPAGE="https://git.oriole.systems/lifeboat"
+SRC_URI="https://git.oriole.systems/lifeboat/snapshot/${P}.tar.gz"
+
+RESTRICT="mirror"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ acct-group/lifeboat
+ acct-user/lifeboat"
+
+RDEPEND="${DEPEND}
+ app-backup/restic
+ net-misc/rclone"
+BDEPEND=""
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}