aboutsummaryrefslogtreecommitdiffstats
path: root/app-admin/kern/kern-0.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/kern/kern-0.3.0.ebuild')
-rw-r--r--app-admin/kern/kern-0.3.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/kern/kern-0.3.0.ebuild b/app-admin/kern/kern-0.3.0.ebuild
new file mode 100644
index 0000000..b38b895
--- /dev/null
+++ b/app-admin/kern/kern-0.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3
+
+DESCRIPTION="Configure, build, and install kernels"
+HOMEPAGE="https://oriole.systems"
+EGIT_REPO_URI="https://git.oriole.systems/kern.git"
+EGIT_COMMIT="${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-admin/eclean-kernel
+ app-editors/neovim"
+BDEPEND=""
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}