aboutsummaryrefslogtreecommitdiffstats
path: root/x11-terms/weltschmerz/weltschmerz-1.3.0.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-04-13 17:35:07 +0200
committerWynn Wolf Arbor2020-04-13 17:35:07 +0200
commit9153b07d529b874c16f71932f7e21278f2854f1d (patch)
treee300230a0efd1947ac56b1b0a58c38c4b1f44d1e /x11-terms/weltschmerz/weltschmerz-1.3.0.ebuild
parent9819fe4cf4429e1d28bf3d1798fceac9902fefaf (diff)
downloadpramantha-9153b07d529b874c16f71932f7e21278f2854f1d.tar.gz
x11-terms/weltschmerz: Bump to 1.3.0
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Diffstat (limited to 'x11-terms/weltschmerz/weltschmerz-1.3.0.ebuild')
-rw-r--r--x11-terms/weltschmerz/weltschmerz-1.3.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-terms/weltschmerz/weltschmerz-1.3.0.ebuild b/x11-terms/weltschmerz/weltschmerz-1.3.0.ebuild
new file mode 100644
index 0000000..de8bfd3
--- /dev/null
+++ b/x11-terms/weltschmerz/weltschmerz-1.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.44"
+
+inherit meson vala
+
+DESCRIPTION="A terminal emulator in Vala"
+HOMEPAGE="https://oriole.systems/posts/weltschmerz.html"
+SRC_URI="https://oriole.systems/snapshots/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RESTRICT="mirror"
+
+BDEPEND="$(vala_depend)"
+
+DEPEND="
+ >=x11-libs/vte-0.56.4:2.91[vala]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ vala_src_prepare
+}