aboutsummaryrefslogtreecommitdiffstats
path: root/x11-terms/weltschmerz/weltschmerz-1.2.1.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-01-18 11:30:30 +0100
committerWynn Wolf Arbor2020-01-18 11:30:30 +0100
commite5f59d7a7e7bfff80fbebe08644306a99f01e31b (patch)
tree1ecea707970a9260cf15b153462a869e30e0fe56 /x11-terms/weltschmerz/weltschmerz-1.2.1.ebuild
parent2f95f78159ee861710b9f69dd1f45dc2889d6058 (diff)
downloadpramantha-e5f59d7a7e7bfff80fbebe08644306a99f01e31b.tar.gz
x11-terms/weltschmerz: Bump to 1.2.1
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Diffstat (limited to 'x11-terms/weltschmerz/weltschmerz-1.2.1.ebuild')
-rw-r--r--x11-terms/weltschmerz/weltschmerz-1.2.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-terms/weltschmerz/weltschmerz-1.2.1.ebuild b/x11-terms/weltschmerz/weltschmerz-1.2.1.ebuild
new file mode 100644
index 0000000..97d20c2
--- /dev/null
+++ b/x11-terms/weltschmerz/weltschmerz-1.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.44"
+
+inherit meson vala
+
+DESCRIPTION="A terminal emulator in Vala"
+HOMEPAGE="https://oriole.systems/posts/weltschmerz.html"
+SRC_URI="https://oriole.systems/snapshots/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RESTRICT="mirror"
+
+BDEPEND="
+ >=dev-lang/vala-0.44.9:0.44"
+
+DEPEND="
+ >=x11-libs/vte-0.56.4:2.91[vala]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ vala_src_prepare
+}