aboutsummaryrefslogtreecommitdiffstats
path: root/www-servers/caddy/caddy-2.5.1.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2022-07-10 10:51:31 +0200
committerWolfgang Müller2022-07-10 10:51:31 +0200
commit478b85a49662f84f0564f33dd856d557fd43c264 (patch)
tree95a19693db0eb377e64fb384b3ab8ecd3a13ded6 /www-servers/caddy/caddy-2.5.1.ebuild
parentdb8eabfc84816068ed822070922477289522b007 (diff)
downloadpramantha-478b85a49662f84f0564f33dd856d557fd43c264.tar.gz
www-servers/caddy: add 2.5.1, drop 2.5.0
Diffstat (limited to 'www-servers/caddy/caddy-2.5.1.ebuild')
-rw-r--r--www-servers/caddy/caddy-2.5.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-servers/caddy/caddy-2.5.1.ebuild b/www-servers/caddy/caddy-2.5.1.ebuild
new file mode 100644
index 0000000..772fb21
--- /dev/null
+++ b/www-servers/caddy/caddy-2.5.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit fcaps go-module
+
+DESCRIPTION="Fast, cross-platform HTTP/2 web server with automatic HTTPS"
+HOMEPAGE="https://caddyserver.com"
+
+DEPEND="
+ acct-user/caddy
+ acct-group/http"
+
+FILECAPS=(
+ cap_net_bind_service /usr/bin/caddy
+)
+
+SRC_URI="https://github.com/caddyserver/caddy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://nest.oriole.systems/gentoo/go-mod/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD ECL-2.0 MIT"
+SLOT="0"
+KEYWORDS="amd64"
+
+RESTRICT+=" mirror test"
+
+src_compile() {
+ go build ./cmd/caddy || die
+}
+
+src_install() {
+ dobin caddy
+ dodoc README.md
+
+ newinitd "${FILESDIR}"/caddy.initd caddy
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+}