aboutsummaryrefslogtreecommitdiffstats
path: root/www-servers/caddy-bin/caddy-bin-1.0.4-r2.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-05-25 14:31:35 +0200
committerWynn Wolf Arbor2020-05-25 14:31:35 +0200
commitcc2a49d67c44bdb420de43fdf0e69fe182eaade8 (patch)
treea95c7baaf63e3fd7d1a51e790366049f2ca98474 /www-servers/caddy-bin/caddy-bin-1.0.4-r2.ebuild
parent2ea27a7de8ea0f09d55c2fb51a2485195b554542 (diff)
downloadpramantha-cc2a49d67c44bdb420de43fdf0e69fe182eaade8.tar.gz
www-servers/caddy-bin: Bump to 1.0.4-r2
Remove diropts invocation in favour of the changes in 2ea27a7, ensuring correct directory permission and ownership through acct-user/caddy. Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to 'www-servers/caddy-bin/caddy-bin-1.0.4-r2.ebuild')
-rw-r--r--www-servers/caddy-bin/caddy-bin-1.0.4-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/www-servers/caddy-bin/caddy-bin-1.0.4-r2.ebuild b/www-servers/caddy-bin/caddy-bin-1.0.4-r2.ebuild
new file mode 100644
index 0000000..567d3f0
--- /dev/null
+++ b/www-servers/caddy-bin/caddy-bin-1.0.4-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fcaps
+
+DESCRIPTION="Fast, cross-platform HTTP/2 web server with automatic HTTPS"
+HOMEPAGE="https://github.com/mholt/caddy"
+
+SRC_URI="https://github.com/caddyserver/caddy/releases/download/v${PV}/caddy_v${PV}_linux_amd64.tar.gz"
+KEYWORDS="amd64"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ acct-user/caddy
+ acct-group/http"
+
+RDEPEND="!www-servers/caddy"
+
+FILECAPS=( cap_net_bind_service+ep /usr/bin/caddy )
+
+RESTRICT="test mirror"
+
+S="${WORKDIR}"
+
+src_install() {
+ dobin caddy
+
+ newinitd "${FILESDIR}"/caddy.initd caddy
+ newconfd "${FILESDIR}"/caddy.confd caddy
+}