aboutsummaryrefslogtreecommitdiffstats
path: root/www-servers/caddy-bin/caddy-bin-1.0.4-r1.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-05-25 14:24:56 +0200
committerWynn Wolf Arbor2020-05-25 14:24:56 +0200
commitcfbf0ded2389798b1e7f3c64cdbd676b55fbf3e9 (patch)
treef459a00dbf9a64bd6a7d95fc0dc3e325940358aa /www-servers/caddy-bin/caddy-bin-1.0.4-r1.ebuild
parentda2f06c3da0d000f7617dac7b4199643c53ab440 (diff)
downloadpramantha-cfbf0ded2389798b1e7f3c64cdbd676b55fbf3e9.tar.gz
www-servers/caddy-bin: Bump to 1.0.4-r1
Use GLEP 81 for the caddy user and group. Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to 'www-servers/caddy-bin/caddy-bin-1.0.4-r1.ebuild')
-rw-r--r--www-servers/caddy-bin/caddy-bin-1.0.4-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/www-servers/caddy-bin/caddy-bin-1.0.4-r1.ebuild b/www-servers/caddy-bin/caddy-bin-1.0.4-r1.ebuild
new file mode 100644
index 0000000..7fc7264
--- /dev/null
+++ b/www-servers/caddy-bin/caddy-bin-1.0.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fcaps
+
+DESCRIPTION="Fast, cross-platform HTTP/2 web server with automatic HTTPS"
+HOMEPAGE="https://github.com/mholt/caddy"
+
+SRC_URI="https://github.com/caddyserver/caddy/releases/download/v${PV}/caddy_v${PV}_linux_amd64.tar.gz"
+KEYWORDS="amd64"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ acct-user/caddy
+ acct-group/http"
+
+RDEPEND="!www-servers/caddy"
+
+FILECAPS=( cap_net_bind_service+ep /usr/bin/caddy )
+
+RESTRICT="test mirror"
+
+S="${WORKDIR}"
+
+src_install() {
+ dobin caddy
+
+ newinitd "${FILESDIR}"/caddy.initd caddy
+ newconfd "${FILESDIR}"/caddy.confd caddy
+
+ diropts -o caddy -g root -m 750 /var/lib/caddy
+}