aboutsummaryrefslogtreecommitdiffstats
path: root/www-misc/slowcgi/slowcgi-7.0.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2021-10-29 11:49:11 +0200
committerWolfgang Müller2021-10-29 11:49:11 +0200
commitef7aed48e056b58d106be2640b591d8022f86bfb (patch)
tree203b3a3c734663a1a0f7173c9190b3905a1d617f /www-misc/slowcgi/slowcgi-7.0.ebuild
parentd0b65ab0ad36bf693bbd71104d55814996d9eefd (diff)
downloadpramantha-ef7aed48e056b58d106be2640b591d8022f86bfb.tar.gz
www-misc/slowcgi: Bump to 7.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Diffstat (limited to 'www-misc/slowcgi/slowcgi-7.0.ebuild')
-rw-r--r--www-misc/slowcgi/slowcgi-7.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/www-misc/slowcgi/slowcgi-7.0.ebuild b/www-misc/slowcgi/slowcgi-7.0.ebuild
new file mode 100644
index 0000000..8ed5723
--- /dev/null
+++ b/www-misc/slowcgi/slowcgi-7.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="a FastCGI to CGI wrapper server"
+HOMEPAGE="https://git.oriole.systems/slowcgi"
+SRC_URI="https://git.oriole.systems/slowcgi/snapshot/${P}.tar.gz"
+
+RESTRICT="mirror"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ acct-user/slowcgi
+ acct-group/http"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-Add-flag-to-run-in-the-foreground.patch"
+)
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/slowcgi.initd slowcgi
+ newconfd "${FILESDIR}"/slowcgi.confd slowcgi
+}