aboutsummaryrefslogtreecommitdiffstats
path: root/www-misc/skein/skein-0.1.3-r2.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2024-09-26 20:16:29 +0200
committerWolfgang Müller2024-09-26 20:16:29 +0200
commitdf64b5a1abb7c847d12344ad70aecc073e895e25 (patch)
treebed383b015fed679b3e91104ec2efe3f6e4e5bf8 /www-misc/skein/skein-0.1.3-r2.ebuild
parenta788e3ac201aebd60704de2049783a4e0902f3cf (diff)
downloadpramantha-df64b5a1abb7c847d12344ad70aecc073e895e25.tar.gz
www-misc/skein: depend on sec-keys/signify-keys-oriole-systems
Diffstat (limited to 'www-misc/skein/skein-0.1.3-r2.ebuild')
-rw-r--r--www-misc/skein/skein-0.1.3-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/www-misc/skein/skein-0.1.3-r2.ebuild b/www-misc/skein/skein-0.1.3-r2.ebuild
new file mode 100644
index 0000000..33c7afc
--- /dev/null
+++ b/www-misc/skein/skein-0.1.3-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_METHOD="signify"
+inherit verify-sig
+
+DESCRIPTION="secure cgit hosting with slowcgi(8)"
+HOMEPAGE="https://git.oriole.systems/skein"
+SRC_URI="
+ https://git.oriole.systems/${PN}/snapshot/${P}.tar.gz
+ verify-sig? (
+ https://git.oriole.systems/${PN}/snapshot/${P}.tar.gz.asc
+ -> ${P}.sha.sig
+ )
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="mirror"
+
+RDEPEND="www-misc/slowcgi"
+BDEPEND="verify-sig? ( sec-keys/signify-keys-oriole-systems )"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/signify-keys/oriole-systems-20240330.pub"
+
+src_unpack() {
+ if use verify-sig; then
+ cp "${DISTDIR}"/${P}.{sha.sig,tar.gz} "${WORKDIR}" || die
+ verify-sig_verify_signed_checksums \
+ ${P}.sha.sig sha256 ${P}.tar.gz
+ fi
+ default
+}
+
+src_compile() {
+ emake LDFLAGS="-static"
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/skein-infra.initd skein-infra
+}