aboutsummaryrefslogtreecommitdiffstats
path: root/www-misc/skein/skein-0.1.1.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-06-04 12:32:36 +0200
committerWynn Wolf Arbor2020-06-04 12:32:36 +0200
commitf4b915a9ab4fdecbf757c623b5c5576b1129c0f6 (patch)
tree09ba183afcd04d646bf5818bd426aaeded5f03dc /www-misc/skein/skein-0.1.1.ebuild
parentd48ff48c04e50f6af49ac57f6a54b8055fc2d3c9 (diff)
downloadpramantha-f4b915a9ab4fdecbf757c623b5c5576b1129c0f6.tar.gz
www-misc/skein: Bump to 0.1.1
Use a regular snapshot instead of cloning the git repository and checking out a specific tag. Fix the homepage URL. Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to 'www-misc/skein/skein-0.1.1.ebuild')
-rw-r--r--www-misc/skein/skein-0.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/www-misc/skein/skein-0.1.1.ebuild b/www-misc/skein/skein-0.1.1.ebuild
new file mode 100644
index 0000000..a1dcf83
--- /dev/null
+++ b/www-misc/skein/skein-0.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="secure cgit hosting with slowcgi(8)"
+HOMEPAGE="https://git.oriole.systems/skein"
+SRC_URI="https://git.oriole.systems/skein/snapshot/${P}.tar.gz"
+
+RESTRICT="mirror"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ www-misc/slowcgi
+ >=www-apps/cgit-1.2.3-r3[static]
+"
+
+src_compile() {
+ emake LDFLAGS="-static"
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/skein-infra.initd skein-infra
+}