aboutsummaryrefslogtreecommitdiffstats
path: root/www-apps/sblg/sblg-0.5.8.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-01-13 15:59:49 +0100
committerWynn Wolf Arbor2020-01-13 15:59:49 +0100
commit90b60b5044587535e792ed5410acbf10a76963e7 (patch)
tree316d681581cb2b3a4218f31e72cab376e70b8252 /www-apps/sblg/sblg-0.5.8.ebuild
downloadpramantha-90b60b5044587535e792ed5410acbf10a76963e7.tar.gz
Initial import
Diffstat (limited to 'www-apps/sblg/sblg-0.5.8.ebuild')
-rw-r--r--www-apps/sblg/sblg-0.5.8.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/www-apps/sblg/sblg-0.5.8.ebuild b/www-apps/sblg/sblg-0.5.8.ebuild
new file mode 100644
index 0000000..228cea6
--- /dev/null
+++ b/www-apps/sblg/sblg-0.5.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple off-line blog utility"
+HOMEPAGE="https://kristaps.bsd.lv/sblg/"
+SRC_URI="https://kristaps.bsd.lv/sblg/snapshots/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/expat"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+RESTRICT="mirror"
+
+src_configure() {
+ ./configure PREFIX="${EPREFIX}/usr" MANDIR="${EPREFIX}/usr/share/man"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+}