aboutsummaryrefslogtreecommitdiffstats
path: root/www-apps/sblg/sblg-0.5.12.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2024-09-24 12:19:14 +0200
committerWolfgang Müller2024-09-24 12:19:43 +0200
commit88a62f42d210d7162e3898486e9ec644c38e2599 (patch)
treeed9306be0df32ee866d2bb63296e38f29b233123 /www-apps/sblg/sblg-0.5.12.ebuild
parent781e68ac5ae03c7d764216f92fc512b2587c49c9 (diff)
downloadpramantha-88a62f42d210d7162e3898486e9ec644c38e2599.tar.gz
www-apps/sblg: add 0.5.12, drop 0.5.11
Diffstat (limited to 'www-apps/sblg/sblg-0.5.12.ebuild')
-rw-r--r--www-apps/sblg/sblg-0.5.12.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/www-apps/sblg/sblg-0.5.12.ebuild b/www-apps/sblg/sblg-0.5.12.ebuild
new file mode 100644
index 0000000..d6300c2
--- /dev/null
+++ b/www-apps/sblg/sblg-0.5.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple off-line blog utility"
+HOMEPAGE="https://kristaps.bsd.lv/sblg/"
+SRC_URI="https://kristaps.bsd.lv/sblg/snapshots/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+DEPEND="dev-libs/expat"
+RDEPEND="${DEPEND}"
+
+RESTRICT="mirror"
+
+src_configure() {
+ ./configure PREFIX="${EPREFIX}/usr" MANDIR="${EPREFIX}/usr/share/man"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if ! use examples; then
+ rm -rf "${ED}/usr/share/${PN}/examples" || die
+ fi
+}