aboutsummaryrefslogtreecommitdiffstats
path: root/www-apps/cgit/cgit-1.2.3-r2.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-05-26 15:46:45 +0200
committerWynn Wolf Arbor2020-05-26 15:46:45 +0200
commit2bba0e5eb6e39b29d2c819bf329bb72179f1518a (patch)
tree189d786d2300dca8f66183fdeefacf9c7a4c71ce /www-apps/cgit/cgit-1.2.3-r2.ebuild
parent375aee3c489dccd8fed2a26cd0aa25a45b3b01a3 (diff)
downloadpramantha-2bba0e5eb6e39b29d2c819bf329bb72179f1518a.tar.gz
www-apps/cgit: Bump to 1.2.3-r3
Add support for a static build. Since e6b07da278, git does not use OpenSSL's SHA1 implementation anymore and instead uses its own DC_SHA1. The only other part of git that depends on ssl is git-imap-send (which is not used by cgit), so drop the ssl dependency from cgit. Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to 'www-apps/cgit/cgit-1.2.3-r2.ebuild')
-rw-r--r--www-apps/cgit/cgit-1.2.3-r2.ebuild91
1 files changed, 0 insertions, 91 deletions
diff --git a/www-apps/cgit/cgit-1.2.3-r2.ebuild b/www-apps/cgit/cgit-1.2.3-r2.ebuild
deleted file mode 100644
index a801587..0000000
--- a/www-apps/cgit/cgit-1.2.3-r2.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib toolchain-funcs
-
-GIT_V="2.25.1"
-
-DESCRIPTION="a fast web-interface for git repositories"
-HOMEPAGE="https://git.zx2c4.com/cgit/about"
-SRC_URI="https://www.kernel.org/pub/software/scm/git/git-${GIT_V}.tar.xz
- https://git.zx2c4.com/cgit/snapshot/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc highlight libressl lua luajit lzip markdown zip zstd"
-
-LUADEP="
- lua? (
- luajit? ( dev-lang/luajit )
- !luajit? ( dev-lang/lua:0 )
- )
-"
-
-BDEPEND="
- doc? ( app-text/docbook-xsl-stylesheets
- >=app-text/asciidoc-8.5.1 )
-"
-
-RDEPEND="${LUADEP}
- dev-vcs/git
- highlight? ( || ( dev-python/pygments app-text/highlight ) )
- lzip? ( app-arch/lzip )
- markdown? ( dev-python/markdown )
- zip? ( app-arch/zip )
- zstd? ( app-arch/zstd )
-"
-
-DEPEND="${LUADEP}
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- sys-libs/zlib
-"
-
-src_prepare() {
- default
-
- rmdir git || die
- mv "${WORKDIR}"/git-"${GIT_V}" git || die
-
- echo "prefix = ${EPREFIX}/usr" >> cgit.conf
- echo "libdir = ${EPREFIX}/usr/$(get_libdir)" >> cgit.conf
- echo "CACHE_ROOT = ${CGIT_CACHEDIR}" >> cgit.conf
- echo "DESTDIR = ${D}" >> cgit.conf
- if use lua; then
- if use luajit; then
- echo "LUA_PKGCONFIG = luajit" >> cgit.conf
- else
- echo "LUA_PKGCONFIG = lua" >> cgit.conf
- fi
- else
- echo "NO_LUA = 1" >> cgit.conf
- fi
-}
-
-src_configure() {
- myopts=(
- $(usex elibc_musl NO_REGEX=NeedsStartEnd '')
- )
-
- export MY_MAKEOPTS="${myopts[@]}"
-}
-
-src_compile() {
- emake ${MY_MAKEOPTS} V=1 AR="$(tc-getAR)" CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
- use doc && emake V=1 doc-man
-}
-
-src_install() {
- emake ${MY_MAKEOPTS} V=1 AR="$(tc-getAR)" CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" install
-
- dodoc README
- use doc && doman cgitrc.5
-}
-
-pkg_postinst() {
- ewarn "For caching support, /var/cache/cgit needs to exist and be owned"
- ewarn "by the user executing cgit."
-}