aboutsummaryrefslogtreecommitdiffstats
path: root/sys-fs/zfs_autobackup/zfs_autobackup-3.3.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2025-02-06 09:58:43 +0100
committerWolfgang Müller2025-02-06 10:00:06 +0100
commitc185087a8b5b14c4cf75091abe57c2dd911a0a31 (patch)
treeb181f430dad28df12121df8b4c838507a0feadec /sys-fs/zfs_autobackup/zfs_autobackup-3.3.ebuild
parent37efd0930b454a82bdf1e39ed5c049ea10260b8c (diff)
downloadpramantha-c185087a8b5b14c4cf75091abe57c2dd911a0a31.tar.gz
sys-fs/zfs_autobackup: add 3.3, drop 3.2-r1
Diffstat (limited to 'sys-fs/zfs_autobackup/zfs_autobackup-3.3.ebuild')
-rw-r--r--sys-fs/zfs_autobackup/zfs_autobackup-3.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-fs/zfs_autobackup/zfs_autobackup-3.3.ebuild b/sys-fs/zfs_autobackup/zfs_autobackup-3.3.ebuild
new file mode 100644
index 0000000..6df78b5
--- /dev/null
+++ b/sys-fs/zfs_autobackup/zfs_autobackup-3.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Periodicly backup ZFS filesystems"
+HOMEPAGE="https://github.com/psy0rz/zfs_autobackup https://pypi.org/project/zfs-autobackup/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+KEYWORDS="amd64 x86"
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/colorama[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"