aboutsummaryrefslogtreecommitdiffstats
path: root/sys-fs/zfs_autobackup/zfs_autobackup-3.2.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2023-08-30 16:09:37 +0200
committerWolfgang Müller2023-08-30 16:09:37 +0200
commite936235f52e4ddc0a2fc5f814462bf573b0cb792 (patch)
tree2d6c5f88f49cb888db74dda0b2827a4eda5cc050 /sys-fs/zfs_autobackup/zfs_autobackup-3.2.ebuild
parent5d30910bafa36a1b229a6fe393f5fc1154647ddd (diff)
downloadpramantha-e936235f52e4ddc0a2fc5f814462bf573b0cb792.tar.gz
sys-fs/zfs_autobackup: add 3.2, drop 3.1.3-r1
Diffstat (limited to 'sys-fs/zfs_autobackup/zfs_autobackup-3.2.ebuild')
-rw-r--r--sys-fs/zfs_autobackup/zfs_autobackup-3.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-fs/zfs_autobackup/zfs_autobackup-3.2.ebuild b/sys-fs/zfs_autobackup/zfs_autobackup-3.2.ebuild
new file mode 100644
index 0000000..7aaa302
--- /dev/null
+++ b/sys-fs/zfs_autobackup/zfs_autobackup-3.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10,11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Periodicly backup ZFS filesystems"
+HOMEPAGE="https://github.com/psy0rz/zfs_autobackup https://pypi.org/project/zfs-autobackup/"
+
+KEYWORDS="amd64 x86"
+
+RESTRICT="test"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/colorama[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"